I have a macbook 5.1 running with mac os x 10.5.8, do i need to buy snow leopard to run sonos?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Yes. Sonos requires Mac OS X 10.6 or higher to run.

    Was this useful? Answer 1

    0 of 1 people found this useful

Related Questions