do i need snow leopard to download the mac app store?

Follow this Question

2 Answers from the Community

  • Best Answer:

    Yes.

    You need OS 10.6.6 or later (eg: 10.7 (Lion), 10.8 (Mountain Lion), 10.9 (Mavericks)) to have the App Store app so you can download apps and current OS.

    The Snow Leopard that comes on disk may be OS 10.6.3. After installation do Software Update to bring up to OS 10.6.8.

    Was this useful? Answer 1

    5 of 5 people found this useful

  • Essentially yes. According to Wikipedia, the Mac App Store was introduced with the 10.6.6 update of Snow Leopard. You don't "download" the Mac App Store directly, you just run Software Update and it will be installed automatically with the relevant update.

    Was this useful? Answer 2

    3 of 6 people found this useful

Similar Questions

See more Similar Questions