Will the newest version of the Airport Extreme work with Windows 7? Not just Windows XP or Windows Vista.

I have an iMac 24in" computer that I completely love but my laptop I am considering upgrading it to Windows 7. Now if I do this, do I just have to instal the AirPort Utility v.5.5 and it will still work?

  • Asked by Anthony V from Vacaville
  • Dec 11, 2009
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

2 Answers from the Community

  • Best Answer:

    Yes, first install the software from the included CD to your computer before connecting the AEBS to anything. Then you'll always be able to setup and administer the base station from either computer.

    • Answered by Andrew H from Carmel
    • Feb 9, 2010
  • By newest version I assume you mean dual band. If so then yes. I have an iMac and laptop PC running off the Airport Extreme with no issues. I can't remember if I installed the utility or not, but it works.

    • Answered by Gary G from Marietta
    • Dec 25, 2009