will it work with MacPro3,1????

  • Asked by Wailun C
  • Mar 26, 2011
ATI Radeon HD 5870 Graphics Upgrade Kit for Mac Pro (Mid 2010 or Early 2009)

ATI Radeon HD 5870 Graphics Upgrade Kit for Mac Pro (Mid 2010 or Early 2009)

Product No Longer Available

2 Answers from the Community

  • Best Answer:

    Yes I have been using the 5870 in my 3,1 for several months without any issues.
    You must be running 10.6.6 or later to support the card.

    Gaming in Bootcamp/Vista is fantastic with the 5870.

    • Answered by Sze Chit H from Singapore
    • Mar 28, 2011
  • I have a 3,1 Mac Pro and it works flawlessly.
    You need 10.6.6 or later.
    Thanks ... Ken

    • Answered by Ken G from Beaverton
    • Mar 28, 2011