will airport extreme work with mac osx 10.4.11

QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

1 Answer from the Community

  • Best Answer:

    You can use it with 10.4.11 once it is set up, but you'll need someone with 10.5 or higher to set it up for you