Why does this require a Mac Pro (Mid 2010)? Q+A suggests older mac pro's may work? I would like to buy this, but am afraid to.

Why does the description on the apple page tell us that a mid 2010 mac pro is required?

Reading Q+A, this seems to be inaccurate.

I am afraid to buy this. But I would like a video card with a mini-dvi port, and not sure what my options are for a 2007 mac pro is currently uses a NVIDIA GeForce 7300 T.

  • Asked by Neil J
  • Oct 15, 2010
ATI Radeon HD 5770 Graphics Upgrade Kit for Mac Pro (Mid 2010)

ATI Radeon HD 5770 Graphics Upgrade Kit for Mac Pro (Mid 2010)

Product No Longer Available

4 Answers from the Community

  • Answer

    I installed this card in a mac pro 1,1 running 10.6.4 and it "worked" but was not fully supported - the card could not be calibrated or run on all resolutions, and some graphics heavy programs (phocus for example) crashed on startup. Upgrading to 10.6.5 has resolved all problems on my machine - the card works perfectly all be it my mac pro is 3+ years old.

    HTH

    • Answered by Tim A from Manchester
    • Dec 13, 2010
  • The latest MAC OSX is required to drive the cards. Furthermore, the PCIe bus speeds differ from Mac Pro generations. This card operates better with the faster bus speeds in the later Mac Pros. If you put this card in the earliest Intel Mac pro, if will probably work with the latest MAC OSX 10.6.5 but not at its optimum performance. If the card is waiting for data from a slow PCI bus, it may be a waste of money to upgrade to this card when you should first upgrade your mac. With that said, the 1GB of VRAM (video memory) on the card would certainly help performance over those cards with only 512KB of less. This card is supposed to be lower in power consumption than the earlier ATI 4870 card for the Mac. Lower power consumption means less heat and less fan noise.

    • Answered by Bill A from Mission Viejo
    • Dec 18, 2010
  • I just bought and installed one in my 2006 Mac Pro. It runs perfectly. The installation instructions are specifically for a 2010 Mac Pro, but if you are unsure how to install it in your mac, just read the instructions that came with your mac about installing graphics cards.

    • Answered by Emma W from North Turramurra
    • Oct 20, 2010
  • Here's the thing: from any tech support standard, when a new device is released, they may not test it on older systems. In this case, they likely just tested the newer Mac's; since they did not test or design it for the older ones, they cannot say that it will definitely work. This is on ATI to test, and they may not have felt that it was necessary to do the testing further back. All that being said, it's up to us end users to take the plunge and test for ourselves. Personally speaking, I've seen enough stats and reviews here that I will likely be buying this for my 2007 Mac Pro.

    • Answered by John S from New Lenox
    • Oct 18, 2010