Which is the most recent Mac OS that will run Parallels v. 6?

I presently have 10.6.8 and know that Mavaricks won't work. What about the lions?

  • Asked by Paul K from Kennett Square
  • Jan 20, 2014
Parallels Desktop 9 for Mac

Parallels Desktop 9 for Mac

Product No Longer Available

No Answers have been submitted