What if I only have my current version installed on my NON intel G5, and change to an Intel one will the upgrade still work, and how ?

  • Asked by Basil H from Tamworth
  • Oct 26, 2009
QA Logic Studio

QA Logic Studio

Product No Longer Available

1 Answer from the Community

  • Which upgrade - the computer? Yes - the older versions of Logic work on both PPC and intel macs. From v9 you can only have it on intel.

    • Answered by Richard W
    • Jan 15, 2010