Requires OS 10.5.7 for admin setup? I'm running 10.4.11 (G4 PowerBook) so I can't do setup or administration?

QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

1 Answer from the Community

  • mac with OS X 10.5x or later. Windows XP SP 3 or greater to set up.