OS 10.5?

Will this work with os 10.5? I am very skeptical about upgrading to 10.6 after all the bad I've heard about it.

  • Asked by Todd W from Albany
  • Sep 2, 2010
ATI Radeon HD 5870 Graphics Upgrade Kit for Mac Pro (Mid 2010 or Early 2009)

ATI Radeon HD 5870 Graphics Upgrade Kit for Mac Pro (Mid 2010 or Early 2009)

Product No Longer Available

2 Answers from the Community

  • Answer

    10.6 as of 10.6.1 or 10.6.2 was as reliable as 10.5 so you shouldn't fear the upgrade. That said, no these cards won't work with 10.5 as they require the drivers that are bundled in 10.6.4 (ATI 5000 series).

    • Answered by Dylan N from Toronto
    • Sep 12, 2010
  • No. As clearly stated in the product description, this card requires Mac OS X 10.6.4 or later.

    • Answered by Matthew R from Santa Fe
    • Mar 18, 2012