I've a 2.4 GHz Int cr 2 Duo w/a Wrlss Crd Type: AirPort Extreme, mdl: fw+,do I need to download the 108. enabler? I cannot run the 2007-002 program.

  • Asked by Gary M from Milo
  • Dec 16, 2009
QA Apple Time Capsule

QA Apple Time Capsule

Product No Longer Available

1 Answer from the Community

  • NO!

    • Answered by Kevin H
    • Feb 2, 2011