Is there any possible way to set up the Airport Extreme base station on my tiger 10.4.11 or do I have to upgrade my software before using it?

  • Asked by かりーな 石 from 名古屋市西区牛島町
  • Nov 27, 2009
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

1 Answer from the Community

  • Answer

    Sorry, No. You must have 10.5.7 or later to set up the Airport Extreme, or any other Airport device.

    • Answered by Janice H from Findlay
    • Jun 24, 2011