is there a version of iBank that will run in OS 10.5.8 on a Dual 1.8 GHz PowerPC G5 Mac

  • Asked by Liz G
  • Oct 26, 2010
iBank 4

iBank 4

Product No Longer Available

1 Answer from the Community

  • Best Answer:

    iBank 4 runs on Mac OS X 10.5.7 or higher, and on both Intel or PowerPC processors. You should have no difficulties with iBank on your G5.

    • Answered by Scott B from Putney
    • Oct 27, 2010