Is the newest ibank 4 compatible with snow leopard

  • Asked by Nicole P from Hockessin
  • Feb 5, 2012
iBank 4

iBank 4

Product No Longer Available

1 Answer from the Community

  • Answer

    Yes. iBank 4 is fully compatible with both Snow Leopard (10.6) and Lion (10.7). Its minimum recommended system requirement is OS X 10.5.7.

    • Answered by Scott B from Putney
    • Feb 6, 2012