Is software compatible with OS X 7.2

I am contemplating purchase of a sheet-fed scanner. I am running OS X 7.2. I first purchased an Epson GT 50S and am returning it because only drivers are supported for 7.2.

I am now considering the Fujitsu S1500M but want assurance that all its software has been upgraded to run on 7.2, Is this the case?

  • Asked by Bernhard K from Goodyear
  • Oct 21, 2011
Fujitsu ScanSnap S1500M Sheet-Fed Scanner for Macintosh

Fujitsu ScanSnap S1500M Sheet-Fed Scanner for Macintosh

Product No Longer Available

1 Answer from the Community

  • Best Answer:

    Yes, the currently shipping S1500M is compatible with OSX 7.2. HOWEVER, the unit ships with Adobe Acrobat 9 Pro which is NOT compatible with OSX 7, Lion. Lion requires Acrobat X Pro.

    Bad situation, as the Acrobat is a major component and one of the best reasons for buying this scanner.

    • Answered by Luke S from Wilkesboro
    • Feb 12, 2012