I haveA Powerbook PowerPCG4 and a MacBook Pro(Intel core 2) which are running OS10.4.11. Can I setup Airport Extreme without upgrading to SnowLeopard

  • Asked by Nicholas C from Irving
  • Apr 17, 2010
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

1 Answer from the Community

  • Answer

    The minimum System Requirement for a Mac is 10.5.7

    Most of the complaining reviews you will read are from those who did not meet the minimum, but tried it anyway:))

    • Answered by Andrew H from Carmel
    • Apr 18, 2010