i have an older airport extreme. Will it work with mountain lion? Have the new iMac but I don't have the install disc that came with the old extreme

  • Asked by Debbie W from Oviedo
  • Dec 12, 2012
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

1 Answer from the Community

  • Yes. That's my setup. You shouldn't need the setup disk, as the Airport Utility is built-in to ML. If you do though, you can download it from Apple. I upgraded all my machines to ML with no issues.

    • Answered by Todd J from Columbus
    • Jan 2, 2013