I have an old macbook pro with 2.06 gHZ and it runs on OS X 10.4 Tiger. Is this compatible with airport extreme?

  • Asked by David K from Houston
  • Dec 8, 2010
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

No Answers have been submitted