I have a MacBook, OS X version 10.4.11. Will the new Airport Extreme work with my computer?

  • Asked by Kathleen G from Chicago
  • Feb 5, 2010
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

1 Answer from the Community

  • Best Answer:

    Yes, this will work with your MacBook, however, your MacBook will not be able to setup and administer this latest version of the AirPort Extreme Base Station unless your Mac meets the System Requirement of OS X 10.5.7 or later.

    For the least expensive solution, get Snow Leopard for your MacBook.

    If you would rather not change your Operating System, consider the previous AirPort Extreme dual-N Base Station which is now available refurbished from the Special Deals section of the online Apple Store for $50 less than new. It has the exact same warranty as the new one, but only needs OS X 10.4 as a minimum System Requirement. It has simultaneous dual networks and the guest networking feature - the only feature it lacks is the MIMO technology which you might not care about since the two networks will give you the same end result.

    • Answered by Andrew H from Carmel
    • Feb 6, 2010