I have a late 2007 iMac running 10.4 Tiger. Is this AirPort Extreme compatible or do I need to upgrade to Leopard or Snow Leopard?

  • Asked by Alana B from Preston
  • Jan 5, 2010
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

1 Answer from the Community

  • Best Answer:

    Although your Tiger iMac and much lesser systems would be compatible to join and use the resulting network, there must first be a computer which meets the minimum System Requirements for setting up and administering this base station so as to be able to establish a working network.

    To avoid unnecessary expense, you might consider the refurbished prior model which is available in the Special Deals section of the online Apple Store. That model, the FB763LL/A, also a dual-band with Gigabit Ethernet model and guest network function, although with somewhat lower range, has a minimum requirement of Tiger OS X 10.4 for setup and administration. I'm using one now and it works great - far superior to the also n-speed AirPort Extreme model which preceeded it, but which was not dual-band.

    • Answered by Andrew H from Carmel
    • Jan 10, 2010