I have a i mac powerPC G4 (half bowling ball model) and am running OS X version 10.4.11 -- can i install and use the airport extreme?

My concern before trying to set up is does 10.4.11 work or do i need 10.5 installed to do set up and administration or airport extreme

  • Asked by Kenneth P from Middleton
  • Dec 10, 2009
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

1 Answer from the Community

  • hi there, from looking it up, for the latest version of the extreme you need Mac OS X v10.5.7 or later for it to work correctly for setup, sorry about that mate

    • Answered by Jacob T from Nottingham
    • Feb 27, 2013