I have a dual processor G5 2.7GHz power mac pro will it work with this...

  • Asked by Steve C
  • Sep 20, 2010
QA Apple 27-inch LED Cinema Display

QA Apple 27-inch LED Cinema Display

Product No Longer Available

2 Answers from the Community

  • Answer

    No. The Apple LED Cinema Display requires Snow Leopard 10.6.4, which cannot be installed on the Power Mac, as Leopard was the last OS X release to support PowerPC CPUs.

    • Answered by Geoff S
    • Sep 29, 2010
  • No. Your mac must be running 10.6.8 and power pc processors are not supported.

    • Answered by David T from Mindemoya
    • Sep 24, 2010