hello, i have a dual 2 gig G5, i've heard despite the minimum requirements, that logic 9 will work on G5s. anybody know if this is true or not?

  • Asked by Kenny P
  • Jan 5, 2010
QA Logic Studio

QA Logic Studio

Product No Longer Available

1 Answer from the Community

  • Works ok on mine. Not the fastest.

    Read similar on many forums..

    • Answered by Walter H from Short Hills
    • Jan 19, 2011