Does this printer work with 10.6.8?

  • Asked by Zoe C from Laval
  • Oct 13, 2012
Epson Expression Home XP-400 Small-in-One Printer

Epson Expression Home XP-400 Small-in-One Printer

Product No Longer Available

1 Answer from the Community

  • Answer

    The minimum software is 10.5.8, so yes, it will work.

    • Answered by Cynthia G from Chatham
    • Nov 30, 2012