Does iBank 4 work with Mountain Lion (OS X 10.8.2)?

  • Asked by Robert R from Bozeman
  • Nov 26, 2012
iBank 4

iBank 4

Product No Longer Available

1 Answer from the Community

  • Answer

    Yes, iBank 4 is fully compatible with all versions of Mountain Lion OS X 10.8. (The minimum required OS is 10.6.)

    • Answered by Scott B from Putney
    • Dec 7, 2012