does airport extreme work with Macbook pro 13 inch?

I have the earlier version 2011

Processor 2.3ghz intel core i5

software mac os x lion 10.7.1

I wanted to know before i buy, Because i went and bought a cisco linksys E3200; However, it only works with OS X leopard 10.5 or Snow leopard 10.6

  • Asked by Rakeem C from Bronx
  • Oct 22, 2011
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

1 Answer from the Community

  • Answer

    It works, and many, many owners are using what you are.

    • Answered by Andrew H from Carmel
    • Oct 28, 2011