can i use logic studio programe on non apple computers

QA Logic Studio

QA Logic Studio

Product No Longer Available

1 Answer from the Community

  • As in windows? No, you need to have Mac OS X 10.5.4 or higher...