Can i run saber system with parallels?

I have an IMAC and just installed Mountain Lion. Previously, I had used parallels 4.0 on my IMAC with the Leopard. Now, I cannot use my Sabre system. The computer tells me that Parallels 4.0 will not work on Mountain Lion. If I purchase Paralells 8.0 (the newest Parallels) will I be able to open my Sabre system which is the travel agent's operating system? Thank you.

  • Asked by Robert G Z from Worcester
  • Feb 1, 2013
Parallels Desktop 8 for Mac

Parallels Desktop 8 for Mac

Product No Longer Available

No Answers have been submitted