Airport Extreme 802.11n requires MacOSX10.5.7 or later. We have Mac 10.4.11. Will it work for us? Brenda

Our Mac 10.4.11 has an airport card that has never been activated. Our latest airport update is 2008001. I notice that a number of other questions ask the same - but there are no answers. (we have a computer not a notebook)

  • Asked by Brenda T from Garibaldi Highlands
  • Dec 24, 2009
QA AirPort Extreme Base Station

QA AirPort Extreme Base Station

Product No Longer Available

No Answers have been submitted