Is this mouse Snow Leopard compatible or not?

The stats say it's compatible with "Mac OS X v.10.4 or later", but the user review titled "Impressive yet..." says there are features that can't be accessed with Snow Leopard.

I realize "compatible" could just mean "yes it works with Snow Leopard, but you can't do everything with it that you could do with Windows".

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Yes. You do need to install the logitech driver.

    Was this useful? Answer 1

    4 of 4 people found this useful

Related Questions