Will it work with OS X 10.4.11

I have an old mac G5 with OS X 10.4.11.

AirPort Extreme

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Unfortunately, Snow Leopard will not work on a Mac with a G5 processor. The processor must be Intel-based.

    Snow Leopard will install on top of OS 10.4.11 on a Mac with an Intel processor. (The G5 is a PowerPC processor, not an Intel processor.)

    Was this useful? Answer 1

    8 of 8 people found this useful

Related Questions