Snow Leopard Compatible?

Will this new model work with 10.6.8?

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Yes, but the new base station requires Airport Utilities 6.3 for set up and administration which is compatible for 10.7+ only. (10.6 uses Airport Utility 5.6 which won't work).
    However, you can use the free Airport Utility app v1.3 on any iPhone or iPad to control the setup.

    Was this useful? Answer 1

    2 of 3 people found this useful

Related Questions