Can you extend the new AirPort Extreme to an older generation airport express (aprox 2008)?

AirPort Extreme

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Yes. However, I had to go back to an older computer that had Airport Utility version 6 before Airport Extreme was able to recognize Airport Express. I was able to update to version 7 after that with my current computer.

    Was this useful? Answer 1

    3 of 3 people found this useful

Related Questions