Will the new Time Capsule work with machines running 10.6.8?

The product info suggests 10.7.5 and a much higher Airport Utility are required, but the info also says it is compatible with any WiFi device.

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    It is possible to set up and administer the device using the Airport Utility 1.3 for iOS if you have an iPhone/iPad, once set up, all features of the device should work natively with 10.6.8 (apart from admin, which you will need the iOS device for.)

    Was this useful? Answer 1

    3 of 3 people found this useful

Related Questions