Can I use the new Time Capsule on machines running 10.6.8?

Product Info says:

Any Wi-Fi device you have will work with AirPort Time Capsule.

But Tech Specs says this Time Capsule requires 10.7.5 and a higher Airport Utility that 10.6 supports.

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Yes, but only if you also have an iOS device.

    I was looking at exactly the same situation, so here's what I've learned, hope it is useful.

    The Mac OS X system requirements for setting the AirPort time capsule require Lion 10.7.5 for setup and administration — however if you have an iPhone/iPad device running running iOS 5 and also have AirPort Utility 1.3 (free from the App Store) it is possible to set up and administrate the unit wholely from your iOS device.

    All other features should work fine, as:

    - Time Machine backups are supported from 10.5.7+
    - Shared printing is supported from 10.2.7+
    - Sharing a connected USB hard drive is supported as of 10.4.8

    Technically, any wi-fi enabled device should be able to connect to the module once set up. — The one handicap you will face is the need to set your device up from an iPhone/iPad.

    Note: I hear the user interface on the iPad app is the best, as it provides the best information about your devices.

    Was this useful? Answer 1

    15 of 15 people found this useful

Related Questions