will this work for my iBook G4? and/or do I have to buy anything additional with the disc upgrade?

my IBook is vs. 10.4.11

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    No, the iBook G4 only runs up to 10.5.8 (Leopard) so you can not run Snow Leopard. Snow Leopard only works on Intel Macs, and the first Mac laptop to use an Intel Processor was the MacBook, which you may be able to find at a decent price now.

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions