Will Snow Leopard work on MacBook Early 2008? I'd hate to buy this and find out it doesn't work.

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Minimum requirements for Snow Leopard are: 1) Intel-based Mac, 2) at least 1 GB of RAM, 3) 5 GB hard drive space, 4) DVD drive.

    It works on my 2007 Intel-based iMac. I think your MacBook is Intel-based also. Go to the Apple Menu and select "About This Mac" to see if your MacBook meets the requirements.

    Snow Leopard costs US$29 at the Apple Store.

    Was this useful? Answer 1

    9 of 11 people found this useful

Related Questions