will os 10.6 work with an emac?

Back To Product

Follow this Question

1 Answer from the Community

  • No, it's not an intel Mac, so you need to get Leopard 10.5. That's as far as you can go. Now, about that new iMac purchase on February, 24, 2011...

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions