Will my Final Cut Studio 1, CS4, and Office07 work with Snow Leopard?

I have an 2.33 intel MacBook Pro 17" / 2g ram, with tiger 10.4.11 and want to upgrade to snow leopard, or even just leopard, but need to keep my existing software for now, including: Final Cut Studio 1, Office 07, and CS4. I also have Aperture 1. Does snow leopard support these older versions..????

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    Final Cut Studio 1, CS4 should all work with Snow Leopard. Office 2007? That is the Windows version of Office. Do you mean Office 2008 Mac? If so, Yes it will word via rosetta.

    Was this useful? Answer 1

    2 of 3 people found this useful

Related Questions