will 10.6 only work on intel macs and why cant I install om older mac mini?

Back To Product

Follow this Question

1 Answer from the Community

  • Snow Leopard will not work on Powerbooks and Powermacs.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions