safari 5 with mac osx 10.6.3?

Hi, I've bought upgrade - Snow Leopard 10.6.3 about week ago and I'd like to download Safari 5. Is that possible? Because on the download page it's said i should have 10.5 or 10.6.4.

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Safari 5 for 10.6.3 is no longer available. You need to update your system. Click the Apple menu, then Software Update. You should see the 'Mac OS X update combined" item in it. Just install it and you'll be able to install Safari 5. You're system version must be 10.6.5 from now....

    Was this useful? Answer 1

    57 of 84 people found this useful

Related Questions