Os10.6 for MacBook white

Can I install 10,66 on my MacBook 3 ,1 intel duo core 2.2ghz running 10.5.8?

Back To Product

Follow this Question

1 Answer from the Community

  • Best Answer:

    Yes.

    Snow Leopard requires an intel-based Mac (which you have) and at least 1GB of memory.

    When you install from the DVD, you may be installing a version earlier than 10.6.6. Simply select "Software Update" from the Apple menu to update to the latest version (currently 10.6.8).

    Was this useful? Answer 1

    6 of 8 people found this useful

Related Questions