My Imac is OS X 10.4.11 and I have ilife but I can't use it because I don't have the latest version, would this help?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    You have 10.4 (Tiger) which requires the Mac Box Set to upgrade to Snow Leopard. The Mac Box Set includes iLife '09 and iWork '09. Your question did not say what version of iLife you have but I'm guessing it's '09 because that requires at least 10.5 (Leopard). You can try to return / sell / giveaway that copy of iLife '09 as the Mac Box Set will include it.

    Was this useful? Answer 1

    1 of 1 people found this useful

  • iLife 09 requires Mac OS X v10.5.6 Leopard or later so yes, this upgrade will support your iLife. Also be sure to check if the processor is an Intel or PowerPC before trying to upgrade to Snow Leopard as Snow Leopard requires an Intel Mac.
    Andy

    Was this useful? Answer 2

    1 of 1 people found this useful

Related Questions