my computer has 10.5.8 i need 10.6 above to connect itunes to ipad will this work with this software. intel core 2 duo 4 gb 1067mhz

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

2 Answers from the Community

  • It's hard to be sure without knowing the exact model of your Mac, but the specs you give are consistent with the system requirements for OS X 10.6 Snow Leopard.

    Was this useful? Answer 1

    0 of 0 people found this useful

  • The latest version of iTunes requires Snow Leopard (OS 10.6.8) or later.

    Your Mac will run Snow Leopard with no problem. Buy Snow Leopard DVD and install.* After install do "Software Update" (under Apple Menu) to update to OS 10.6.8.

    iTunes is available from:
    wwwDOTappleDOTcom/itunes/download/ (replace each "DOT" with ".")

    Minimum System Requirements for iPad:
    supportDOTappleDOTcom/kb/HT4081

    * Note: if your Mac does not have an optical drive, you have two options:
    1) put your Mac on a network with another Mac that has an optical drive. Do a remote install (instructions are on the Snow Leopard Install disk).
    2) Format a USB flash drive or a partition on an external hard drive (flash drive or partition needs to be at least 8GB in size). The formatting needs to be "Mac OS Extended (Journaled)" with GUID option. On a Mac with a working optical drive, use disk utility to RESTORE the DVD to the flash drive or partition. Connect flash drive or external hard drive to your Mac and use Start Up Disk to start up from the flash drive or partition. Continue with install.

    Was this useful? Answer 2

    0 of 0 people found this useful

Related Questions