Is this what is considered the 'Retail' version?

Essentially, would I be able to install this on any Apple hardware?

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question