Is there a Quickbooks version that will run on Snow Leopard?

I have Mac OS X 10.6.8 Snow Leopard, but all the versions of the Quickbooks software for Mac I'm finding are only compatible with Lion or Mountain Lion. What can I do about this?

Thanks!

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    According to Intuit, "QuickBooks for Mac 2012" requires OS 10.6.7 or OS 10.7 and later. I don't understand why OS 10.6.8 seems to be skipped.

    Perhaps send a query directly to Intuit to confirm whether this version of QuickBooks will run on OS 10.6.8.

    "QuickBooks for Mac 2011" requires OS 10.6 or OS 10.7.

    "QuickBooks for Mac 2013" requires OS 10.7 or OS 10.8.

    "QuickBooks for Mac 2014" requires OS 10.7 or OS 10.8.

    Was this useful? Answer 1

    2 of 3 people found this useful

Related Questions