is my HP Laserjet 1600 printer compatible with Snow Leopard

At the moment I am running OS 5.8 and don't seem to be able to find drivers for my HP Laserjet 1600 printer that will work with this. This model of printer seems to be supported by Snow Leopard, is this the case? If so do I need to upgrade to Snow Leopard in order to use my printer. I have an entry level Mac Book.

Back To Product

Follow this Question

1 Answer from the Community

Related Questions