iPad not working with itunes I'm use in osx 10.4.11 I need 10.5 wot software do I need..

Do I need snow leopard box set

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    to upgrade from 10.4.11 on an intel mac to snow leopard 10.6 you will need the mac box set (10.6.4, iLife, iWork) and then download iTunes 9.2.1 to use your iPad

    Was this useful? Answer 1

    3 of 5 people found this useful

Related Questions