Internet Explorer

Does the Snow Leopard upgrade let you run Internet Explorer in version higher than 5.2 what ever. This is important because I use my computer for work and there are some sites that I can not access with safari.

Back To Product

Follow this Question

3 Answers from the Community

  • Best Answer:

    You could use a virtualization tool for this. On the list of often used applications are VMWare Fusion, Microsoft VirtualPC, , Parallels Desktop, CrossOver 7, Bootcamp, etc. There are also several browsers that *may* help bypass that issue. Firefox, Opera, and Google Chrome are on the short list. If you're running into issues due to activeX, the virtualization option is the best I recommend.

    Was this useful? Answer 1

    9 of 11 people found this useful

  • no internet explorer will not run versions higher than 5 on a mac.... you could try downloading mozilla firefox and see if that works =)

    Was this useful? Answer 2

    10 of 14 people found this useful

  • no

    Was this useful? Answer 3

    1 of 3 people found this useful

Related Questions