I want to upgrade my MAC OS X 10.5.8 to use icloud with my new iphone 4S. What software and OS upgrades will I need to make this work?

Build 9L31a
2.8 GHz Intel Core 2 Duo
4 GB 667 MHz DDR2 SDRAM

Mac OS X 10.6 Snow Leopard

Back To Product

Follow this Question

2 Answers from the Community

  • Answer

    Did you upgrade successfully? I am curious. I have an older Macbook Pro (circa 2008) and the upgrade to Lion pretty much destroyed it. I've had to erase and reformat the hard drive, and reinstall Leopard to get it working again. With Lion, it would not boot to anything but a scrambled screen. The geniuses at the Apple store told me a I needed a $750 video card. Sure, on a 4 year old machine.

    Once I started doing more research, I found out this was a rampant issue and that Apple was aware of it. Luckily, I have a non-Apple backup (iDrive for Mac) and was able to restore the majority of my documents, music and photos. I've lost some things, some apps, some music, but most of all, my faith and opinion in/of Apple. This is not malicious, just a fact.

    Of well. Consider yourself warned about Lion with older machines. Great features in Lion, just best used on a newer machine. I still prefer Apple to the alternative, but they are no longer on the pedestal I had them on before.

    Was this useful? Answer 1

    4 of 4 people found this useful

  • you will need mac os x lion 10.7.2 or 10.7.3. iCloud is no available with snow leopard 10.6

    Was this useful? Answer 2

    2 of 2 people found this useful

Related Questions